본문 바로가기
백준/코딩연습1

[백준] 단어 정렬 (1181)(java)

by 유줘니 2019. 5. 16.

원본 문제 : https://www.acmicpc.net/problem/1181

문제 참고 : https://bcp0109.tistory.com/5

 

문제

알파벳 소문자로 이루어진 N개의 단어가 들어오면 아래와 같은 조건에 따라 정렬하는 프로그램을 작성하시오.

  1. 길이가 짧은 것부터
  2. 길이가 같으면 사전 순으로

입력

첫째 줄에 단어의 개수 N이 주어진다. (1≤N≤20,000) 둘째 줄부터 N개의 줄에 걸쳐 알파벳 소문자로 이루어진 단어가 한 줄에 하나씩 주어진다. 주어지는 문자열의 길이는 50을 넘지 않는다.

출력

조건에 따라 정렬하여 단어들을 출력한다. 단, 같은 단어가 여러 번 입력된 경우에는 한 번씩만 출력한다.

예제 입력 1

13

but

i

wont

hesitate

no

more

no

more

it

cannot

wait

im

yours

예제 출력 1

i

im

it

no

but

more

wait

wont

yours

cannot

hesitate

 

 

 

 

 

 

import java.util.ArrayList;
import java.util.Collections;
import java.util.Comparator;
import java.util.HashSet;
import java.util.Scanner;

public class Main {

	public static void main(String[] args) {
		
		Scanner sc = new Scanner(System.in);
		final int N = Integer.parseInt(sc.nextLine());
		
        //단어의 중복을 제거하기 위해 set을 사용
		HashSet<String> set = new HashSet<String>();
		
		for(int i = 0; i < N ; i++)
			set.add(sc.nextLine());
		
        //set을 list로 변환
		ArrayList<String> list = new ArrayList<String>(set);
		
        //Collections와 new Comparator를 통해 커스텀 정렬
		Collections.sort(list, new Comparator<String>() {

			public int compare(String o1, String o2) {
            
            	//문자열 길이 비교 (1)
				if(o1.length() > o2.length())
					return 1;
                //문자열 길이 비교 (2)
				else if(o1.length() < o2.length())
					return -1;
                //문자열 길이가 같으면 알파벳순 정렬
				else
					return o1.compareTo(o2);
			}
		});
		
		for(String s : list)
			System.out.println(s);
	}
}

댓글