본문 바로가기
백준/코딩연습1

[백준] 균형잡힌 세상 (4949)(java)

by 유줘니 2019. 5. 16.

원본 문제 : https://www.acmicpc.net/problem/4949

 

문제

세계는 균형이 잘 잡혀있어야 한다. 양과 음, 빛과 어둠 그리고 왼쪽 괄호와 오른쪽 괄호처럼 말이다.

정민이의 임무는 어떤 문자열이 주어졌을 때, 괄호들의 균형이 잘 맞춰져 있는지 판단하는 프로그램을 짜는 것이다.

문자열에 포함되는 괄호는 소괄호("()") 와 대괄호("[]")로 2종류이고, 문자열이 균형을 이루는 조건은 아래와 같다.

  • 모든 왼쪽 소괄호("(")는 오른쪽 소괄호(")")와만 짝을 이룰 수 있다.
  • 모든 왼쪽 대괄호("[")는 오른쪽 대괄호("]")와만 짝을 이룰 수 있다.
  • 모든 오른쪽 괄호들은 자신과 짝을 이룰 수 있는 왼쪽 괄호가 존재한다.
  • 모든 괄호들의 짝은 1:1 매칭만 가능하다. 즉, 괄호 하나가 둘 이상의 괄호와 짝지어지지 않는다.
  • 짝을 이루는 두 괄호가 있을 때, 그 사이에 있는 문자열도 균형이 잡혀야 한다.

정민이를 도와 문자열이 주어졌을 때 균형잡힌 문자열인지 아닌지를 판단해보자.

입력

하나 또는 여러줄에 걸쳐서 문자열이 주어진다. 각 문자열은 영문 알파벳, 공백, 소괄호("( )") 대괄호("[ ]")등으로 이루어져 있으며, 길이는 100글자보다 작거나 같다.

입력의 종료조건으로 맨 마지막에 점 하나(".")가 들어온다.

출력

각 줄마다 해당 문자열이 균형을 이루고 있으면 "yes"를, 아니면 "no"를 출력한다.

예제 입력 1

So when I die (the [first] I will see in (heaven) is a score list).

[ first in ] ( first out ).

Half Moon tonight (At least it is better than no Moon at all].

A rope may form )( a trail in a maze.

Help( I[m being held prisoner in a fortune cookie factory)].

([ (([( [ ] ) ( ) (( ))] )) ]).

  .

.

예제 출력 1

yes

yes

no

no

no

yes

yes

 

 

 

오답 1

5번째 문장에서 yes로 출력되는 문제가 있다.

'('와 ')', '['와']'가 수가 맞아도 문제가 되는 경우다.

import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.util.ArrayList;
import java.util.Iterator;
import java.util.Stack;

public class Main {

	public static void main(String[] args) throws IOException {
		BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
		
		ArrayList<String> list = new ArrayList<String>();
		
		
		while(true) {
			String str = br.readLine();
			if(str.charAt(0)=='.') break;
			list.add(str);
		}
		
		Iterator iter = list.iterator();
		
		while(iter.hasNext()) {
			String str = (String)iter.next();
			
			System.out.println(str);
			if(str.charAt(0)=='.') break;

			Stack<Character> stack1 = new Stack<Character>();
			Stack<Character> stack2 = new Stack<Character>();
			
			try {
				for(int i = 0; i < str.length() ; i++) {
					if(str.charAt(i)=='(')
						stack1.push(str.charAt(i));
					else if(str.charAt(i)==')')
						stack1.pop();
					else if(str.charAt(i)=='[')
						stack2.push(str.charAt(i));
					else if(str.charAt(i)==']')
						stack2.pop();
				}
				
				if(stack1.isEmpty()&&stack2.isEmpty()) 
					System.out.println("yes");
				else
					System.out.println("no");
			} catch (Exception e1) {
				System.out.println("no");
			}
		}
	}
}

 

 

오답 2

문제 설명 중에

  • 짝을 이루는 두 괄호가 있을 때, 그 사이에 있는 문자열도 균형이 잡혀야 한다.

라는 조건에서 문제가 발생하는 거 같았다. 괄호들은 문자 사이에 끼면 안된다고 해석이 되어

if조건문에 여러가지 조건을 추가해 결과대로 출력하는데 성공했지만 문제는 계속 틀렸다고 나왔다.

import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.util.ArrayList;
import java.util.Iterator;
import java.util.Stack;

public class BOJ4949 {

	public static void main(String[] args) throws IOException {
		BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
		
		ArrayList<String> list = new ArrayList<String>();
		
		
		while(true) {
			String str = br.readLine();
			if(str.charAt(0)=='.') break;
			list.add(str);
		}
		
		Iterator iter = list.iterator();
		
		while(iter.hasNext()) {
			String str = (String)iter.next();
			boolean check = false;

			if(str.charAt(0)=='.') break;

			Stack<Character> stack1 = new Stack<Character>();
			Stack<Character> stack2 = new Stack<Character>();
			
			try {
				for(int i = 0; i < str.length() ; i++) {
					if(str.charAt(i)=='(') {
						if(i>0&&i<str.length()-1&&str.charAt(i-1)>='A'
								&&str.charAt(i-1)<='z'
								&&str.charAt(i+1)>='A'
								&&str.charAt(i+1)<='z') {
							break;
						}
						stack1.push(str.charAt(i));
					}
					else if(str.charAt(i)==')') {
						if(i>0&&i<str.length()-1&&str.charAt(i-1)>='A'
								&&str.charAt(i-1)<='z'
								&&str.charAt(i+1)>='A'
								&&str.charAt(i+1)<='z') {
							break;
						}
						stack1.pop();
					}
					else if(str.charAt(i)=='[') {
						if(i>0&&i<str.length()-1&&str.charAt(i-1)>='A'
								&&str.charAt(i-1)<='z'
								&&str.charAt(i+1)>='A'
								&&str.charAt(i+1)<='z') {
							break;
						}
						stack2.push(str.charAt(i));
					}
					else if(str.charAt(i)==']') {
						if(i>0&&i<str.length()-1&&str.charAt(i-1)>='A'
								&&str.charAt(i-1)<='z'
								&&str.charAt(i+1)>='A'
								&&str.charAt(i+1)<='z') {
							break;
						}
						stack2.pop();
					}
				}
				
				if(stack1.isEmpty()&&stack2.isEmpty()) 
					System.out.println("yes");
				else
					System.out.println("no");
				
			} catch (Exception e1) {
				System.out.println("no");
			}
		}
	}
}

 

 

 

문제 풀이(정답)

간단한 스택개념으로 해결할 수 있는 문제였다.

문자열이 어떻게 되든 상관 없이 ')' (닫히는)괄호가 오면

그 이전에 stack에 저장된 괄호는 그 쌍의 괄호인 '(' 이어야 한다.

이러한 짝이 맞는지를 보는 문제였다.

import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.util.ArrayList;
import java.util.Iterator;
import java.util.Stack;

public class Main {

	public static void main(String[] args) throws IOException {
		BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
		
		ArrayList<String> list = new ArrayList<String>();
		
		
		while(true) {
			String str = br.readLine();
			if(str.charAt(0)=='.') break;
			list.add(str);
		}
		
		Iterator iter = list.iterator();
		
		while(iter.hasNext()) {
			String str = (String)iter.next();
			boolean check = false;

			if(str.charAt(0)=='.') break;

			Stack<Character> stack = new Stack<Character>();
			
			try {
				for(int i = 0; i < str.length() ; i++) {
					if(str.charAt(i)=='(') {
						stack.push(str.charAt(i));
					}
					else if(str.charAt(i)==')') {
						if(!(stack.peek()=='(')) break;
						else stack.pop();
					}
					else if(str.charAt(i)=='[') {
						stack.push(str.charAt(i));
					}
					else if(str.charAt(i)==']') {
						if(!(stack.peek()=='[')) break;
						else stack.pop();
					}
				}
				
				if(stack.isEmpty()) 
					System.out.println("yes");
				else
					System.out.println("no");
				
			} catch (Exception e1) {
				System.out.println("no");
			}
		}
	}
}

 

 

 

댓글